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Course Objectives 

 
• Design and create a spreadsheet:  

 Data, Labels, Formulas & Functions 
• Successfully format spread sheets 
• Present data in charts 
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Getting Started with Excel 

  Create a New Workbook Exercise 1

1. Double click on the Excel icon to start 
your spreadsheet session. 

 
 
Screen Overview 

 
   

 File Tab This Tab replaces the 2007 Office Button and the 2003 File Menu 
providing access to Backstage View and the program control centre. 

 Quick Access Bar Always visible and provides access to tools on Office Button. 

 Ribbon  Replaces the Menu Bar and offers a visual reference to all tools 
available in Word. Can be set to minimise when not actively in use. 

 Status Bar Now offers a customised option to add and remove items. 

 Worksheet Views  Repositioned to right hand side and new magnification option via 
slider. 
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 Labels, Values, Formulas 
Labels = Text 
Values = Numbers 
Formulas = Calculations (A formula always begins with an equal sign, ‘=’) 

  Adding Data to a worksheet Exercise 2
Step 1 – Adding Labels 

 
 
Step 2 – Adding Values 

 

  Adding Formulas to a worksheet Exercise 3
Step 3 - Formulas 
You can use cells in formulas to calculate results in a number of ways: 
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Autofill 
You can use the AutoFill tool to fill data into worksheet cells. You can also have Excel 
automatically continue a series of numbers, number and text combinations, dates, or time 
periods, based on a pattern that you establish. 

  Autofill Exercise 4
1. Enter formula to Autosum on cell B7 
2. Move to bottom right hand corner to 

display ’Autofill’ mouse pointer. ‘     ‘ 
3. Drag across cells (C7:E7)  

Cell References 
Relative References 
Excel adjusts the cell references and copies a formula relative to the answer cell 
By default cell references will be relative cell references unless you specify otherwise 
Absolute References 
There will be times when you want to compare a range of values to a specific cell.  Absolute 
cell references are denoted with $ preceding each col/row reference. i.e. $F$4 

  Using Absolute cell references Exercise 5
We want to find out what percentage each stores' sales were from the total sales.   
We need to consider absolute references in our formula to specify a value in a fixed location 
to be used in our calculations. 
 
 

1. Enter heading “%of Total Sales” in 
column G 

2. Enter the formula =F2/F7 in cell G2 
3. Click the % button in  

Number group  

 
 

Note: These are relative cell references and may give 
unexpected results when we use Autofill. To ensure we 
always refer to the ‘total sales’ figure in our calculations 
this cell has to be an absolute reference 
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1. Go to cell G2 
2. Click in F7 reference in formula 
3. Press the function key F4 to change 

the reference to Absolute; $F$7 
4. Autofill down  

 
Note: Using absolute cell references means this formula 
can be duplicated accurately.   
 
The formulas could be entered manually in 
each cell but Autofill will save time and provide 
consistent results. 

  

  To Freeze panes Exercise 6
1. On the View tab,  
2. Click the arrow beside Freeze Panes 
3. Click Freeze Panes 

 

  

  To Unfreeze panes Exercise 7
 

1. On the View tab,  
2. Click the arrow beside Freeze Panes 
3. Click Unfreeze Panes 
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Functions 
A function is a predefined formula that performs a particular type of computation. All you 
have to do to use a function is supply the values that the function uses when performing its 

calculations - these are the arguments of the function. 

  Using functions in formulas Exercise 8
Using the Average function from command button 

1. Add cell labels 
 Average,  
 Maximum, 
 Minimum 
2. Go to cell B9 
3. Click on Home tab on the ribbon  
4. Click the arrow alongside the Autosum button 
5. Select ‘Average’ 
6. Check the range and change if necessary 
7. Press enter 
 

 
 

 

 
Using the Maximum function on the formula bar 

1. Go to cell B10 
2. Click the Fx button on the formula bar 
3. In the dialogue box, click on the ‘MAX’ function 
4. Click OK 
5. Indicate the range for the Maximum value 
6. Click on OK 

 
 

 
 
 

 
Using the Minimum function from Ribbon 

1. Go to cell B11 
2. Click on Formula tab on the ribbon  
3. Click more Functions command button 
4. Hover mouse over Statistical 
5. Click on MIN function 
6. Type in the range B2:B6 
7. Click on OK 

 
 

 
 
To complete these formulas for all columns 
The Autofill tool,      ,can be used to drag 
across C9:E11  
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Formatting Cells 
The presentation of information can be adjusted by using the ribbon to format individually 
selected elements or by applying a theme to a whole worksheet. 

  Manually Formatting cells Exercise 9
 
NUMBER formats 

1. Select the cell or range of cells you 
want to change:B2:F11 

2. Go to the number group on the ribbon 
3. Click the down arrow alongside the 

general number format 
4. Hover your mouse over the formats 

displayed 
5. To apply a format, click once on your 

chosen option. 
 

 

 

 
CHARACTER Formats 

1. Select the cell or range of cells you 
want to change:A2:F11 

2. Go to the font group in the ribbon 
3. Click the colour command   
4. Hover your mouse over the formats 

displayed 
5. To apply a format, click once on your 

chosen option 

 

 
 

 
DATE Formats  
Format a date to the day it represents. 

1. Enter your birth date into a cell  
Note This will show the default format 
dd/mm/yyyy 

2. Select this cell  
3. On the Home tab,  
4. Click on the number group dialogue 

box launcher 
5. Select the custom option 
6. Enter the format ‘dddd’ 

Note: This will present your birth date as a day 
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  Remove Formatting Exercise 10
 
To return data to the original formats 

1. On the Home tab 
2. Go to the editing group 
3. Click on Clear 
4. Select ‘Clear Formats’ 

 

Cell Comments  
You may want to provide additional information about cell content.  You can do this by 
adding a comment which is hidden from view until selected.   

  Adding a cell Comment Exercise 11

To add a comment 
1. Select the ‘Adelaide’ cell 
2. Click on the Review tab 
3. Click New Comment 
4. Type a comment such as 

“This store opened last month” 
Note: The comment will be displayed as a 

small red triangle in the cell 
 

 

 

Note: To keep a comment visible with the cell, you can select the cell that contains the comment and 
then click Show/Hide Comment in the Comments group on the Review tab. To display all comments 
with their cells on the worksheet, click Show All Comments. 
Edit a comment 
 

1. Click the Review tab  
2. Click Edit Comment.  

  
Delete a comment 
 

1. Click the Review tab  
2. Click Delete.  
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Moving and Copying Data 
• When you move a formula, the cell references within the formula do not change no 

matter what type of cell reference that you use.  
• When you copy a formula, the cell references may change based on the type of cell 

reference that you use. 

  Rename, move or copy a worksheet Exercise 12

1. Go to the Home tab, 

2. In the Cells group, click Format 

3. Under Organize Sheets, click 

Move or Copy Sheet.  

 

 

 
 
 
 
 
 

 
To book; allows you to choose where the 
sheet should move to. 
 
Before sheet; allows you to indicate where 
the selected sheet should sit. 
 
Create a copy; allows you to copy the 
worksheet rather than move  

 

 
 

  Move Data   Exercise 13

 
 
  

To move a cell or range of cells  
1. Select the cells to move: A2:A6  
2. On the Home tab, click Cut   
3. Go to destination cell; A20 
4. Click Paste  

Or… 
5. Point mouse on the border of the 

selection  
6. Drag the cell or range of cells to 

another location. 

   
 

Note: you can only drag the selection on the same worksheet  



 

 11 of 14 Ask I.T. Microsoft Excel 2010: Level 1 

 Phone: (07) 3356 8811 or 1300 738 082 
 E-mail: help@askit.uq.edu.au 
 Web: http://www.library.uq.edu.au/ask-it/ 
 

  Copy Data  Exercise 14
To copy a cell or range of cells  

1. Select the cells to copy: A20:A26 
2. On the Home tab, click Copy   
3. Go to destination cell; A2 
4. On the Home tab, click Paste  

Or… 
5. Point mouse on the border of the 

selection  
6. Hold CTRL key 
7. Drag the cell or range of cells to 

another location. 

  

Note: you can only drag the selection on the same worksheet  

  Copy formulas  Exercise 15
To copy a cell or range of cells containing formulas  

1. Select the cells to copy: F2:A6 
2. On the Home tab, click Copy   

 

  
 

3. Go to destination cell; F20 
4. On the Home tab, click Paste  

Note: With relative cell references the destination of the 
pasted formulas is important... 

 
  

  Create a Dynamic Link Exercise 16
 

1. Go to Sheet 3 or Summary sheet 
2. Click in cell B2 
3. Enter = 
4. Go to Sales sheet 
5. Click on the cell you want the data from 

F2 
6. Press Enter 

 

Note: Check the formula bar for the cell content.  The link refers to = Sheet1! F3 
 Formula Tab Name Cell 

 
With the relative cell references used, Autofill 
down for other branches 
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Sparklines 
Sparklines is a new tool in Excel 2010 which helps you discover patterns or trends that can 
lead to more informed decisions and improve your ability to analyse large data sets. You can 
create a visual summary of your data using tiny charts that fit within a cell alongside your text 
data with new Sparklines. 

  Insert Sparklines Exercise 17

To Insert Sparklines 
1. Select the cells to display the 

sparklines, H2:H6 
2. Click on the Insert Tab 
3. Click Line in Sparklines group 

 
 

 

4. Select the range to be 
analysed,B2:E6   

5. Click on OK 

  

Charting 

  Create a Chart Exercise 18
 

To Create a chart 
1. Select the cells you wish to chart 

(In exercise file – A1:E6) 
2. Click on the Insert Tab 
3. Select a chart type   

 

 
Note: To quickly create a default chart, select the data that you want to use for the chart, then press 
ALT+F1 – this displays the chart as an embedded chart or  
ALT+F11 – this displays the chart on a separate chart sheet. 
 

Board Games

Dolls and Prams

Computer Games

Lego
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Formatting a Chart 

  Modify a chart Exercise 19
1. Click on the inserted chart 

Note: You will see a contextual tab above the ribbon 
2. Click on the tab to access the appropriate tools 

Note: You can change the Chart Design, Chart Layout and Chart Format 
3. Apply changes to chart as required 

 

Chart Design 

 
Chart Layout 

 
 

Chart Format 
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Printing 

  Preview and Print a Worksheet Exercise 20

To preview a worksheet 
1. Click File tab in ribbon 
2. Select Print option  

 
Note    You will be presented with a Print 
preview of the worksheet and options to choose 
the print settings.  
 
Note: To return to your worksheet,  simply click 
on the Home tab   
 

 

  Defining a print area Exercise 21
Set a print area 

1. Select the cells to define the print 
area. (A1:F11) 

2. Go to the Page Setup group on the 
Page Layout tab 

3. Click Print Area,  
4. Click Set Print Area.  

Note   The print area that you set is saved when 
you save the workbook.  
Clear a print area 

1. Click anywhere on the worksheet  
2. Go to the Page Setup group on the 

Page Layout tab 
3. Click Clear Print Area.  

 

Excel Help Facility 
If you need help with any application tools you can get assistance by clicking the help 
button on the ribbon.  This is located at the right hand side of the screen. 
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