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Course Objectives 
¶ Create and save Word documents 

¶ Format text, paragraphs and 
pages 

¶ Understand and perform editing 
techniques  
(including cut, copy and paste) 

¶ Print documents 

¶ Use tools to automate Word 

¶ Access online Help 
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Getting Started 
 

 

Screen Overview 

 
 

 Ribbon  
A series of tabs that provide easy access to related tool groups. Several 
Ribbons are contextual, and these tabs are only visible when the word 

element, the Ribbon relates to, is selected. For example Table Layout Ribbon. 

 
Cursor 

The blinking vertical line in a document that indicates where text will appear 
when you start to type. 

 
Scrollbar 

Use the mouse and drag this bar up and down or click on the directional 
arrows to see parts of a document that are currently not visible. 

 Ruler 
Displays the vertical and horizontal dimensions of the document. The blue 
shaded regions on the ruler indicate the margin dimensions.  To view ruler, 

click on View menu, then click on Ruler. 

 
Zoom Control Zoom in and out of a document by sliding the zoom control 

 Left click on the Word:MAC 2011 icon to 
start your Word Processing session. 
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Hiding (or Showing) the Ribbon 

By default the Ribbon is displayed as Shown. It may also be hidden and it will appear with 
only the row of Tabs onscreen.  
 
To Hide/or Show the Ribbon: 

¶ Click the View Menu >> Ribbon 

   or 

Click the active Ribbon tab.  
(e.g. if the Home Ribbon is currently 
displayed, click on the Home Tab) 

Note: The Ribbon is Shown when a tick is to 

the left of View Menu >> Ribbon, otherwise it 

is Hidden 

 

 
Activating a Tool on a Hidden Ribbon: 

¶ Click the Tab on which the Tool is 
Housed 

Note: The Tab will activate  

¶ Locate and apply the required Tool 
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The File Location Views 

When using Finder, an Open or a Save dialog box to browse folders and files, there 
are a number of views 

The Dialog box views 

View Button Appearance 

Icon  

 

Presents icons associated with items 

List  
 

 

Lists items and several fields of information  

Column 
 

 

Displays items according to their browsing hierarchy. 
The exception is the final column, which, when a file 
is selected, presents a thumbnail preview and some 
basic file information 
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The Finder views 

View Button Appearance 

Icon  
 

Per above description 

List 
 

Per above description 

Column 
 

Per above description 

Flow 
 

 

Flow showcases either an associated icon, or a 
detailed preview of the selected item in the preview 
pane.  
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File Menu 
The File menu provides the basic commands necessary to open, save, and print your 
documents. 

Opening a New Document 

When you start a Word session a new document called Document 1 is activated.  At any other 
time, to start a new document:  

¶ Click the File menu 

¶ Click on New Blank Document 
 
    or 
 

¶ Click the New button  
 
    or 
 

¶ Type Command +N 
 

Opening an Existing Document 

If you have to retrieve a file from a storage 
source: 

1. Click the File menu 
2. Click on Open or type +O 
3. Browse to the location of your file 
4. Select the existing document you 

want 
5. Click on Open 

 

 
 
 
If you have recently used a file: 

1. Click the File menu 
2. Hover your mouse over Open Recent 

Click on your file from the drop down list that 
appears 

Saving and Closing Documents 

To save a new document 
1. Click the File menu 
2. Click on Save As 
3. Enter a filename for the document 
4. Select the location for the 

document 
5. Select the format of the document  
6. Click on Save 

 

 
To close a document 

1. Click the File menu 
2. Click on Close or type +W 

 
 

Exercise 1.  Entering and Editing Text   
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1. Change the font size to font 36. 
2. Enter the following texté 

The quick brown fox jumps over the lazy dog. 
Press the return/enter key 
 

Notice the flashing cursor as you type.  The text appears to the left of the cursor and it 
moves across the screen to the right. 
 

3. Enter the following texté. 
My friends is noice. 

 
Note: Your finished document should look similar to the text below 
 

 

Editing Information 
 
Notice the green and red lines that appear under the text.  Green means a grammatical error 
and red means a spelling mistake.  Position the cursor half way over the coloured underline 
and right mouse click. A list of possible correction options will appear. Choose from the 
suggested correction choices that appear at the top of the list. 
 

1. Position the cursor at the end of the word ólazyô in the first piece of text 
2. Use the óDeleteô key (above the directional arrows on the keyboard) to see the text to 

the right of the cursor disappear 
3. Use the Backspace / Delete key on the main keyboard to see the text to the left of 

the cursor disappear 
 

Selection Techniques 

Text Selection In Document In Left Margin 

Any amount of text. Click and drag.  
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A word. Double-click  

A line. Click and drag Single Click 

A sentence. Click and drag or +click  

A paragraph. Triple Click Double Click 

An entire document. +A Triple Click 

A section of text 1. Define a starting point (Click at the start of the text you want to select) 

2. Move the mouse cursor to the end of the text you wish to select 
3. Define the ending point (Hold the Shift key and click with the mouse) 

Typing Replaces Selection 

Typing replaces Selection is a feature available in Word, which allows users to replace 
specific pieces of text with alternative text. 
 

 1.  Selection The quick brown fox 

2.  Typing The quick y fox 
3.  Completion The quick yellow fox 
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Formatting Information 
Microsoft Word 2011 formats text by using a very simple principle ï  

ñSelect the text you want to change and then apply the changes to it.ò 
Formatting is applied to text using the Home Tab and the Format Menu. 
 

Exercise 2.  Formatting text 

 

Select the text ñThe quick brown foxò from Exercise 1 

 

 
Using the Formatting options on the Home Tab and in the Format Menu, it is 
possible to change:  
 

 
 

 Font 
The quick brown fox 

 

 Font Size 

 

 

 

The quick brown fox 

 

   Colour and Effects 

 

 

 

The quick brown fox 
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To access the formatting dialog 
boxes:  
 
Use +D to display Dialogue Box 
  
    or 
 
1. Click on the Format menu 
2. Click Font 

 
   or 
 

3. Click Borders and Shading 

 
 
 
 
 
 
 

 
 

 
Use the Font dialog box to change: 
 

¶ Font   

¶ Font Size 

¶ Colour and Effects 

 

 
 

 
Use the Borders and Shading 
dialog box to: 
 

¶ Change the background  

¶ Add a border 
 

1. Click on Format menu 
2. Click Borders and Shadingé 
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Exercise 3.  Using the óFormat Painterô Tool 

A high-speed formatting option is Format Painter. This is a quick way of duplicating 
formatting from one section of text to another. 
 
To use the Format Painter once 

1. Place the cursor in the text whose format you want to copy  
2. Click the Format Painter button in the standard toolbar.  

Note: You will see a plus sign attached to the mouse cursor  

3. Select the text that you want to paint on the new format.  
 
To use the Format Painter repeatedly 

1. Place the cursor in the text whose format you want to copy  
2. Double-Click the Format Painter button.  

Note: You will see a plus sign attached to the mouse cursor  
3. Select the text that you want to paint on the new format.  
4. Click on the Format Painter button to switch off  
 

Exercise 4.  Inserting Page Breaks 

To start typing on a new page when you are ready you can automatically move to a new 
page by inserting a page break.  This can be carried out via the Insert menu. 
 
1. Click on Insert menu 
2. Hover mouse over Break 
3. Click Page Break 

 
    or 
 
1. Choose the Layout Tab 
2. Click on Break button 
3. Click on Page 

 
 
Viewing Non-Printing Characters 
To allow for editing of your document it is often useful to see when a page break, tab 
character or space was inserted. These are generally considered as non-printing characters 
as they donôt print out but you can see them in the document by switching them on. 
 
To view Non-Printing Characters: 

On the Standard toolbar: 
1. Click on Show button 
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Spell check & Proof reading 

Exercise 5.  Spell check the whole document   

The spell check will begin from the insertion point.  It is recommended you move to the 
beginning of the document before commencing. 
 
On the Tools menu 

1. Click on Spelling & Grammaré  
2. You are presented with the spell 

check dialogue box.   
 

 
 

Any spelling error is presented in red and may have alternative suggestions listed. 
 
To leave a spelling error: 

¶ Click on Ignore or Ignore All 
 
To ensure text isnôt picked up as an error 
in future: 

¶ Click on Add 
 
To change a spelling error: 

1. Select the correct suggestion 
2. Click on Change or Change All 

 

 
 
Any grammar error is presented in green and may have alternative suggestions listed. 
 
To leave a grammar error: 

¶ Click on Ignore Once, Ignore All 
or Next Sentence 

 
To change a grammar error: 

1. Select the correct suggestion 
2. Click on Change  

 

Checking Individual errors 

In the status bar the spelling indicator will display a red cross to indicate there are errors in 
the document. 
 
To go to the closest error in the document: 

¶ Click on the spell check icon   
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Cut, Copy & Paste techniques 
When using cut & copy techniques, the information selected is temporarily placed on the 
clipboard for use in another location.  This can be either in the same document, in a 
completely different document or even in a different type of file. 
  
On MAC systems, the clipboard functionality is limited and may require additional software 
such as PTH Pasteboard for optimal usage.  Alternatively, the Scrapbook tool in the 
Formatting Palette can be used for long-term storage and information transfer between files. 
 
 
To open the Clipboard: 

¶ Open Finder 

¶ Click Edit menu 

¶ Click Show Clipboard 
 

 

 

Exercise 6.  Copy & Paste Techniques 

Open a new document for this exercise and type the following text: 
 

Your Name  
Job Title 
Department 
Institution 

 
Using the keyboard & menu: 

To Move text 
1. Select the text you want to move. 
2. Type +X to cut text 

    or 
3. Click Edit menu 
4. Click Cut 
5. Go to the new location for the 

selected text  
6. Type +V 

    or 
7. Click the Edit menu 
8. Click Paste 

To Copy text 
1. Select the text you want to copy. 
2. Type +C to copy text 

    or 
3. Click Edit menu 
4. Click Copy 
5. Go to the new location for the 

selected text 
6. Type +V 

    or 
7. Click the Edit menu 
8. Click Paste 

Using the Mouse 

(the Drag and Drop technique - useful within one document) 
To Move text 

1. Select the text you want to move. 
2. Click on the selection 
3. Drag to the new location for the selected text  

(Note: you will see the selected text attached to the mouse) 
4. Release the mouse button 
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To Copy text 
1. Select the text you want to copy. 
2. Hold down the Option key 
3. Drag to a new location 

(Note: you will see a plus sign attached to the mouse) 
4. Release the mouse button 
5. Release the Option key 

 

 

 

Printing Options  
Printing options in Word 2011 are available from File menu. You can preview or choose your 
own print settings.  
 

Exercise 7.  Print Preview Document 

1. Click File menu 
2. Click Print  
3. Choose Preview on the Print dialogue box 

 

 

Item Grouping Features 

 

Preview Preview the 
print job 
 

 Printer 
settings 

Choose 
printer and 
options  
 

 Pages Choose 
which pages 
to print 

 

 
 

 
 
 
  

1 

2 

3 

1 

2 
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Exercise 8.  Print specific requirements 

1. Click File menu 
2. Click Printé 
3. Use preview buttons to determine 

what you want to print 
4. Indicate settings such as Page range, 

number of Copies, and 
Standard/Duplex printing (depends 
on printer) 

5. Click Print 
 

 

Using the Keyboard to Print 

¶ Press +P. 

                                                                     
To print without using the dialog box 

¶ Click Print icon . 
 
 
 
 
 
 

To Save in PDF format 

1. Repeat steps 1& 2 above 
2. Click PDF button 
3. Click Save as PDFé 
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Auto Correct 
You can use the AutoCorrect feature to correct typing mistakes and misspelled words, as 
well as to insert symbols and other pieces of text. AutoCorrect is set up by default with a list 
of typical misspellings and symbols, but you can modify the list that AutoCorrect uses. 
 
Autocorrect entries will be corrected automatically as soon as you press the space bar after 
entering appropriate text. 
 

 
 

Exercise 9. Use óAuto Correctô Tool 

Type teh and press the spacebar 
Type adn and press the spacebar 
 
Define autocorrections using: 
cahnge   with  change 
ASAP  with  As soon As Possible 
UQL  with  University of Queensland Library 
 
Optionally, if you want to add a formatted text entry, open the document that contains the 
text that is formatted the way that you want, and select that text.  Repeat as above and the 
selected text will automatically be entered into the With box. 
 


